
Faire une courbe de transit d’exoplanète avec des
données IRiS à l’aide du logiciel AstroImageJ

Avertissements : 
> L’objectif de ce tutoriel est d’obtenir la courbe de luminosité du transit de WASP-104b, mais le 
principe décrit ici s’applique à d’autres transits et de manière générale à toute étude 
photométrique ;
> Ce tutoriel s’appuie sur des observations auto-calibrées et ne prend donc pas en compte l’étape
de calibration des images ;

x/ Etape n°x de traitement
→ Commentaire 
> Procédure à suivre : > File > Open
Et des captures d’écran illustrent les opérations à suivre.

1/ Ouverture de la séquence d’images
→ Ouvrir la séquence d’images acquises sur l’étoile hôte de l’exoplanète dont vous cherchez à mesurer 
la variation de luminosité (ici WASP-104).
> File > Import > Image sequence
> Double-cliquer sur la 1ère image de la séquence

Une fenêtre s’ouvre ; elle indique le nombre d’images à charger (ici 197)
Cocher la case Use virtual stack si mémoire nécessaire inférieure à celle de votre PC
> Cliquer sur OK
La séquence d’images à traiter s’ouvre.



2/ Suppression des images indésirables
→ Cette étape consiste à supprimer de la séquence, les images qui n’ont pas d’utilité scientifique : 
mauvaise orientation, mauvaise mise au point, présence d’un objet transitoire perturbant (météorites, 
satellites…).
> Faire défiler la séquence (ascenseur horizontal en bas de la fenêtre) et supprimer les images de 
la séquence (icône en haut à gauche).
Ici, il y a 6 images avec une mauvaise orientation ; la suppression des images avec une mauvaise mise 
au point est plus subjective (celles pour lesquelles les étoiles ont des formes de « patates », ici une 
dizaine).

3/ Alignement des images
→ Cette étape est cruciale car elle va permettre d’aligner toutes les images ; ainsi chaque objet sera 
localisé au même endroit sur l’image ; en effet, au cours d’une observation, le télescope fait une petite 
erreur de pointage qu’il est nécessaire de corriger dans le traitement afin de pouvoir ensuite analyser 
l’évolution du flux lumineux d’un même objet du ciel, et donc sur une zone de pixels identifiée.
→ Pour l’alignement des images, 2 méthodes sont possible : 
- l’alignement relatif des images les unes par rapport aux autres ;
- l’alignement de chacune des images par rapport à un système de référence.
Ici, nous allons utiliser la 2nde solution par rapport au système WCS (World Coordinate System), intégré 
à chacune des données IRiS. 
> Process > Align stack using WCS or apertures …



Une nouvelle fenêtre s'ouvre :
> Attention à bien réaliser l’alignement depuis la 1ère image (first slice) et jusqu’à la dernière 
image ;
> Cocher la case « Use only WCS headers for alignement (no apertures required) ;

> Cliquer sur OK
Le processus d’alignement est lancé.
Si le calcul s’arrête (par exemple parce qu’une image ne possède pas de coordonnées WCS, voir image 
ci-dessous ; ou bien que l’orientation d’une image n’est pas la bonne), il faut alors supprimer l’image en 
question, et relancer le processus d’alignement depuis la 1ère image.

Une fois le calcul terminé, vous pouvez vérifier que les images de la séquence sont bien alignées en les 
faisant défiler grâce à l’ascenseur horizontal.
A ce stade, vous pouvez enregistrer la séquence alignée pour pouvoir les travailler plus tard (ce n’est pas
obligatoire et faites attention à la mémoire!).



> File > Save stack as sequence 
> Sélectionner format « FITS ».

4/ Photométrie multi ouverture
L’objectif est de mesurer l’évolution du flux lumineux de l’étoile WASP-104 pour y détecter le transit de 
l’exoplanète recherchée ici (photométrie). Or les variations de ce flux peuvent être causées par d’autres 
phénomènes que le passage de l’exoplanète devant son étoile, notamment les perturbations 
atmosphériques, la caméra, etc. Pour soustraire ces variations du signal qui nous intéresse, une 
première approche consiste à calibrer le flux de la cible avec des étoiles de comparaison situées dans le 
champ (photométrie multi-ouverture).

4.1/ Identification de la cible
Sur les images acquises par IRiS, la cible est toujours au centre. Or ici pour WASP-104, 2 étoiles sont 
proches du centre. Pour identifier notre cible, il faut se reporter à un catalogue, par exemple sur la base 
de données d’exoplanètes ETD (Exoplanet Transit Database, http://var2.astro.cz/ETD/index.php).
> Rechercher WASP-104b dans la base de données pour obtenir la carte du champ stellaire (voir 
ci-dessous image de gauche).
> En comparant avec les observations d’IRiS, on identifie notre cible (attention, le champ est 
inversé ; image de droite ci-dessous dans l’ellipse rouge).

http://var2.astro.cz/ETD/index.php


3.2/ Détermination des paramètres de la mesure photométrique
Pour réaliser la photométrie multi-ouverture, il est nécessaire de déterminer la surface du détecteur (en 
pixels) sur laquelle l’évolution du flux lumineux sera mesurée. Il faut donc déterminer le nombre de pixels 
(en moyenne) d’une étoile.
Pour cela, choisir une image de la séquence (la première par exemple), et avec le curseur de la souris, 
pointer la cible (étoile au centre) :
> Alt + clic gauche
Une fenêtre s’ouvre :



Noter les 3 valeurs rouge du graphe.
Réitérer l’opération sur d’autres étoiles (notamment celles que vous choisirez comme étoiles de 
calibration, par exemple les 3 étoiles qui forment un triangle au-dessus de la cible) et sur d’autres 
images, et noter les valeurs qui sont les plus grandes.
Ici, on prend : 12, 21, 32.

→ Nous allons ensuite rentrer ces paramètres pour lancer la mesure photométrique.
> Nettoyer l’image (icône balai) 
> Edit > Aperture settings (ou cliquer sur l’icône Set aperture settings)

Une fenêtre s’ouvre : 
> Indiquer les 3 paramètres relevés plus haut, ainsi que les caractéristiques de la caméra d’IRiS 
(voir sur le site web dans la rubrique > IRiS de A à Z > Les propriétés en détail).

3.3/ Mesure photométrique



> Analyze > Multi-Aperture… (ou bien cliquer sur l'icône Perform multi aperture photometry)

Une nouvelle fenêtre s’ouvre. 
> Vérifier les paramètres d’ouverture rentrés précédemment et attention à prendre toutes les 
images de la séquence en commençant bien à l'image numérotée 1.

→ Nous allons désormais sélectionner la cible ainsi que les étoiles de comparaison pour la calibration.
> Cliquer sur Place apertures. 



> Sélectionner la cible (celle identifiée précédemment) qui va apparaître en vert avec le clic 
gauche ;
> Sélectionner les étoiles de comparaison qui seront utilisées pour calibrer le flux (ici, nous en 
sélectionnons 3) qui apparaissent en rouge avec le clic gauche. 

ATTENTION : 
- il faut faire extrêmement attention au choix des étoiles de calibration : pour une mesure plus fine, il 
faudrait notamment s'assurer qu'elles ne soient ni saturées ni variables, qu’elles soient 
approximativement du même type spectral que notre cible, etc. Ici nous n’y ferons pas attention.
Néanmoins, il convient de choisir des étoiles qui ne sont pas situées en bord de champ et dont le flux 
paraît approximativement le même que la cible (valeurs indiquées à côté des cibles choisies) ;
- attention à bien positionner le curseur lors de la sélection des étoiles ; lorsque la souris se déplace, 
vous pouvez voir 3 cercles concentriques ; veiller à bien positionner l’étoile au coeur du cercle intérieur.

→ La sélection des cibles est terminée, la mesure peut être lancée.
> Faire un clic droit pour lancer l'analyse (ou Entrée). 

La mesure est alors lancée et plusieurs fenêtres s’ouvrent (nous allons y revenir dans la partie suivante). 
Parmi ces fenêtres, les 4 courbes de photométrie sont tracées dans « Plot of measurements » (la courbe 



de la cible ainsi que les 3 courbes de calibration).

A ce stade, on distingue le transit sur la courbe de la cible (en bleu ici) avec un creux marqué. Nous 
allons désormais affiner cette courbe et passer en revue différentes options.

4/ Modélisation

4.1/ Paramétrage de la courbe
Les 2 fenêtres principales pour paramétrer les courbes sont « Multi-plot main » et « Multi-plot Y-data ».
> Dans la fenêtre « Multi-plot Y-data » :

- vérifier d’abord que toutes les courbes sont affichées (cocher la case « Plot » pour chaque courbe) ;
- ensuite, vous avez la possibilité de décaler les courbes et de modifier leur échelle afin de pouvoir les 
visualiser sur le même graphe (cocher la case « Page relation » et jouer avec les valeurs de « Scale » et 
« Then shift »).



> Dans la fenêtre « Multi-plot main » :

- dans la rubrique Data (measurements), dans la colonne Y-datasets, indiquer le nombre de courbes à 
afficher (ici, 4 = 1 cible + 3 comparaisons) ;
- au centre, dans les rubriques « Title » et « Subtitle », indiquer les titres et sous-titres de votre graphe ; 
les blocs peuvent être déplacés grâce aux curseurs ;
- la rubrique « Legend » (à droite) concerne le pavé de légende multicolore en haut de la courbe ; il peut 
lui aussi être déplacé ;
- à ce stade, s’assurer que les échelles en X et en Y s’ajustent automatiquement en cochant « Auto X-
range » dans la rubrique « X-Axis Label » et « Auto Y-range » dans la rubrique « Y-Axis Label » ;

Dernière étape avant de lancer la modélisation, il faut obtenir les dates prévues de début et de fin de 
transit.
> Aller sur la base ETD (Exoplanet Transit Database) : http://var2.astro.cz
> Sélectionner « Transit predictions » et recherche la date qui concerne les données de WASP-
104b traitées ici, de 2017-02-25 à 2017-02-26 (en adoptant les notations anglophones du site) ;

http://var2.astro.cz/


Noter que le début du transit de WASP-104b est à 21h43 (TU) le 25/02/17 et la fin du transit est à 23h29 
(TU) le 25/02/17.

→ Pour la modélisation de la courbe, il faut convertir ces dates en jour julien. 

Dans la fenêtre principale d’AstroImageJ :
> Cliquer sur l’icône « Coordinate converter »

Une fenêtre s’ouvre : 

Dans la rubrique « Epoch of interest » :
> Indiquer la date de début de transit relevée précédemment ; à droite est indiquée la conversion 



en jour julien (JD, soit Julian Day) : 2457810.404861
> Faire la même chose pour la fin de transit : 2457810.478472

4.2/ Modélisation de la courbe de transit

> Retour dans la fenêtre « Multi-plot main ». Tout en bas de la fenêtre, renseigner la rubrique « Fit and
normalize region selection » avec les valeurs respectives de début de transit (« Left ») et de fin de transit 
(« Right ») en ne prenant en compte que les valeurs décimales :

> Dans la fenêtre « Multi-plot Y-data », aller dans la colonne « Fit Mode » de la courbe T1 (1ère ligne) 
et choisir dans le menu déroulant la modélisation d’un transit (forme d’un transit) :

Une première modélisation de la courbe s’affiche ainsi qu’une nouvelle fenêtre (encore!) intitulée « Data 
Set 1 Fit Settings ». C’est dans cette fenêtre que sont affichés les résultats de la modélisation du transit 
(paramètres encadrés en vert).

Voici la courbe modélisée à ce stade.



Cette modélisation pourrait être encore affinée (voir plus loin).

4.3/ Sauvegarde des données
Pour enregistrer toutes les données traitées et pouvoir poursuivre le traitement en cours, dans la fenêtre 
« Multi-plot main » :
> File > Save all (with options)…

Une nouvelle fenêtre s’ouvre :



> Cliquer sur Save files now
Choisir le dossier dans lequel seront stockées les données puis choisir les données à sauvegarder dans 
la nouvelle fenêtre (avec les menus déroulants).
> Cliquer sur OK

4.4/ Restauration des données
ATTENTION : toutes les fenêtres sont fermées avant de lancer cette opération.

> Cliquer sur l’icône « Multiplot »
> Cliquer sur l’icône « Read measurement table » puis ouvrez le fichier « nom_measurement.xls » 
sauvegardé à l’étape précédente.

5) Pour aller plus loin
Pour obtenir des résultats d’une meilleure qualité, il est nécessaire d’aller plus loin dans le traitement des 
données. Plusieurs opérations n’ont pas été traitées ici :
- la calibration des données : il s’agit de prendre en compte les défauts du détecteur en intégrant au 
traitement les données de calibration (dark, bias, flat) ; ici, les données sont autocalibrées ;
- le choix des étoiles de comparaison : ces étoiles ne doivent pas être variables, être du même type 
spectral que la cible, ne pas être saturées…
- le jeu sur les paramètres de modélisation…


