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*/ Introduction
1/ Objectifs

Ce tutoriel  s’adresse principalement  aux  enseignants  qui  utilisent  le  télescope IRiS avec leurs  élèves.
L’objectif principal est donc de leur fournir un document leur permettant d’obtenir des images couleurs à
partir des images acquises avec plusieurs filtres spectraux sur IRiS. 

Le logiciel utilisé ici est AstroImageJ (AIJ). Ce logiciel a été choisi pour sa polyvalence, pour sa relative
simplicité d’utilisation, sa reconnaissance par les amateurs et les professionnels ainsi que pour sa gratuité.
Il existe de nombreux autres logiciels de traitement d’images astronomiques mais comme nous ne pouvons
pas rédiger des tutoriels sur tous les logiciels,  nous avons opté pour celui-ci.  Bien entendu, libres aux
utilisateurs d’IRiS d’utiliser d’autres outils qui leur conviendraient mieux. 

Bien  qu’il  soit  polyvalent,  la  vocation  première  d’AIJ  est  l’analyse photométrique (courbes de lumières
d’objets variables) et il ne sera peut-être pas considéré comme l’outil idéal pour réaliser de la trichromie.
Enfin, ce tutoriel n’a pas vocation à explorer toutes les possibilités et toutes les options d’AIJ, il s’agit d’un
document permettant à n’importe qui de réaliser rapidement des images couleurs. De nombreuses options
ne sont pas explorées.

2/ Contenu

Ce tutoriel se divise en 4 partie :
→ p.1 – 2 > L’introduction qui explicite les objectifs du tutoriel, ainsi que quelques rappels sur les filtres
spectraux du télescope IRiS. 

→ p.3 > La partie consacrée à la préparation de l’espace de travail  avant de commencer à traiter les
images. 

→ p.4 – 12 > La partie Traitement des images qui constitue le coeur du tutoriel. Celui-ci s’appuie sur un
exemple précis d’images acquises avec IRiS. Il s’agit de M16 (Nébuleuse de l’Aigle) observé avec 3 filtres
particuliers.  Bien entendu,  ce tutoriel  s’applique à tout  autre objet  et  à  tout  autre filtre.  L’important  est
l’enchaînement des opérations. 
L’édition est la suivante :

x/ Etape n°x de traitement
→ Commentaire 
> Procédure à suivre : > File > Open
Et des captures d’écran illustrent les opérations à suivre.



→ p. 13 – 15 >  La dernière partie est consacrée à quelques annexes traitant des aspects de mémoire
informatique et de quelques conseils pour une bonne exploitation scientifique de la trichromie.

3/ Rappels sur les filtres IRiS
IRiS est  équipé d’une caméra qui observe principalement dans le spectre visible ainsi  que de 9 filtres
photométriques (voir les caractéristiques détaillées sur le site web d’IRiS, http://iris.lam.fr/le-telescope-2/les-
caracteristiques-techniques-en-detail/) : 5 filtres photométriques standards dits « Sloan » à large bande (u’,
g’, r’, i’, z’, voir ci-dessous), 2 filtres à bande étroite (OIII et Halpha), 1 filtre à bande large dit cométaire dans
le proche infrarouge, et enfin la possibilité d’observer sans aucun filtre avec un filtre dit « luminance ».

Ainsi la répartition spectrale des filtres photométriques d’IRiS est la suivante :

Pour réaliser des images couleur des objets observés avec IRiS, il faudra donc associer une couleur à la
longueur d’onde du filtre utilisé. Etant donnée la largeur spectrale de certains filtres, la couleur choisie peut
donc être variable selon la sensibilité de l’utilisateur. Quelque soit la couleur choisie, il est donc important
d’être conscient que l’image obtenue après traitement ne correspond pas à des « couleurs réelles » mais à
des choix facilitant la représentation de ce que nous ne pouvons pas percevoir avec la vision humaine.

http://iris.lam.fr/le-telescope-2/les-caracteristiques-techniques-en-detail/
http://iris.lam.fr/le-telescope-2/les-caracteristiques-techniques-en-detail/


*/ Préparation
1/ Télécharger et installer AIJ.
Ce logiciel est gratuit. Il peut être téléchargé ici : 
www.astro.louisville.edu/software/astroimagej/

2/ Préparer son espace de travail.
Cette étape n’est pas indispensable mais elle facilite les étapes futures de traitement. Cette organisation
permet  de  s’y  retrouver  plus  facilement  entre  les  différentes  couleurs,  et  différencier  les  fichiers
correspondant à des additions d’images, des fichiers sources.

> Créer un dossier (nom de l’objet par exemple) pour y ranger les images au format .fits que vous
souhaitez traiter.
> Créer dans ce dossier autant de sous-dossiers que de couleurs qui seront superposées (dans
l’exemple qui sera traité, trois sous-dossiers associés aux « bleu », « rouge » et « vert » sont créés) :

> Copier et coller dans chacun des dossiers les images correspondantes à chacun des filtres (dans
l’exemple de M16, le filtre g → bleu, le filtre OIII → vert, le filtre Halpha → rouge) :

4/ Démarrer AstroImageJ

> Double cliquer sur l’exécutable « AstroImageJ.exe » 
(ATTENTION : ne pas lancer ij.jar)

http://www.astro.louisville.edu/software/astroimagej/


*/ Traitement des images

→ Obtention de l’image pour la couche bleue
Pour créer une image « couleur », il faut dans un premier temps créer les images « bleu », « rouge » et
« vert » qui seront additionnées par la suite. Chacune de ces images sera obtenue en empilant les images
acquises pour les différents filtres : toutes les images du dossier « bleu » seront empilées et permettront
d’obtenir l’image « bleu », idem pour les autres.

1/ Ouvrir l’ensemble des images classées dans le sous-dossier « bleu » 
 >File > Import > Image Sequence

> Sélectionner les images placées dans le dossier « bleu » :
> Ouvrir

La fenêtre « Sequence Options » s’ouvre. Vérifiez le nombre d’images de la séquence (dans le cas traité ici,
5).

> Cocher uniquement l’option « Sort names numerically »
> OK

→ Une nouvelle fenêtre s’ouvre dans laquelle se trouvent les images sélectionnées.



→ Dans certains cas, certaines images indésirables (mauvaise orientation, défaut de pointage,  trainée
lumineuse...) peuvent être supprimées avant d’effectuer le traitement (voir annexes).

2/ Aligner les images de la séquence
→ A ce stade, les images ne sont pas alignées. Vous pouvez vous en rendre compte en les faisant défiler.
Or l’alignement est indispensable afin de pouvoir additionner les images.

Il y a 2 possibilités (2.1 OU 2.2):

2.1/> Process > Align stack using WCS or apertures …



> Ok
→ La nouvelle séquence d’images alignées est affichée
NB : lors de cette séquence, un message d’erreur indiquant que le logiciel ne parvient pas à aligner les
images car il lui manque une source ; dans ce cas, cliquer sur une étoile puis appuyer sur « Entrée ».

2.2/
> Process > Align Stack using Image Stabilizer

> Cliquer sur Ok
→ La nouvelle séquence d’images alignées est affichée
(ATTENTION : le calcul peut prendre quelques secondes ; quand le travail est terminé, le curseur est 
surmonté d’un double cercle bleu et d’une croix rouge)
→  Renouveler  éventuellement  l’un  ou  l’autre  des  alignements  jusqu’à  ce  que  les  images  soient
parfaitement alignées : les étoiles restent fixes d’une image à l’autre de la séquence.

 >  Faites  défiler  les images pour  vérifier  l’alignement  (à l’aide de l’ascenseur  horizontal  ou des
flèches du clavier).
NB :  il  est  possible de conserver  cette  nouvelle séquence d’images alignées (> File  > save as image
sequence)

3/ Additionner les images de la couche « bleue »
> Process > Combine stack slices into single image
> Dans la fenêtre qui s’ouvre, choisir l’option « Sum slices »



L’image résultant de l’empilement des 5 images alignées s’ouvre dans une nouvelle fenêtre.

4/ Sauvegarder l’image « empilée » de la couche « bleue »
→ Sauvegarder l’image « empilée » au format .fits dans le dossier portant le nom de l’objet où se trouvent
les dossiers « bleu », « rouge » et « vert »:

> File > Save image/slice as fits…
>  Nommer  cette  image  « b »  par
exemple.

>  Fermer  les  2  fenêtres  d’images  et
revenir à la console d’AIJ 

5/ Obtenir les 2 images pour la couche
«     verte     »     et pour la couche «     rouge     »

>Réaliser les mêmes opérations que pour la couche « bleue»  en enregistrant les images obtenues
sous les noms « r » et « v ».

→ Obtention de l’image couleur
Il s’agit désormais de superposer les images associées à chaque couche de couleur, et de leur attribuer
leur couleur respective.

6/ Aligner la séquence d’images associées à chaque couche de couleur
→ Ouvrir la séquence formée par les trois images alignées et empilées obtenues dans les trois filtres
« bleu », « rouge » et « vert »

> File > Import > Image Sequence



 

→ La fenêtre « Sequence options » s’ouvre ; laisser « Number of images : 6 » (AIJ compte 6 fichiers, mais
il n’y a bien que 3 images).

> Cliquer sur OK.

→ Aligner les 3 images avec l’une des commandes :
> Process > Align stack using WCS or apertures …
OU 
> Process > Align stack using image stabilizer

7/ Attribuer les couleurs à chacune des couches
>  Color > Make composite color image

> Dans la fenêtre « Make composite », choisir l’option « Color » et cliquer sur OK.

→ Cette  option  va  permettre  d’attribuer  une couleur  par  image de la  séquence avec au maximum 7
couleurs donc 7 canaux différents. Par défaut, les couleurs attribuées sont dans l’ordre suivant pour les 7
premières images de la séquence : rouge, vert, bleu, cyan, magenta, jaune, gris.

Ici, les couleurs attribuées seront les suivantes :



- Channel 1 : bleu
- Channel 2: rouge
- Channel 3 : vert

→ Pour attribuer les couleurs choisies :
> Cliquer sur More dans la fenêtre « Channels »
> Choisir la couleur associée au canal sélectionné 

> Renouveler l’opération pour le images « r » : Channel 2 à basculer sur « Red » et « v » : Channel 3
à basculer sur « Green ».

8/ Réaliser l’image composite
>  Pour  superposer  les  images  avec  les  couleurs
choisies,  sélectionner  l’option  « Composite »  dans  le
menu déroulant de la fenêtre « Channels ».



→ L’image couleur s’affiche

9/ Ajuster le contraste et la luminosité de l’image obtenue
→ Vous avez plusieurs  possibilités  pour  ajuster  le  « rendu »  de l’image.  Il  ne  s’agit  ici  que d’options
esthétiques.

9.1/  Sur la fenêtre AIJ, adoucissez l’image > Process > Smooth

9.2/ Il est également possible de régler manuellement le contraste et la luminosité de l’image depuis la
fenêtre de l’image :



>  Scale > Full dynamic range
> Réglages avec les 2 curseurs situés en bas de la fenêtre (curseur du haut : luminosité ; curseur du
bas : contraste)

9.3/ Il est possible de revenir aux réglages initiaux :
> Scale > autobrightness & contrast
OU avec l’icône en haut à droite (voir ci-contre) 



9.4/ Il est aussi possible de régler les paramètres de contraste et de luminosité pour chacune des couches
(donc avant de réaliser l’image composite) à l’étape 7.
> Scale > fixed brightness & contrats (per image slice)
> Affiner ses propres réglages pour chacun des canaux puis poursuivre l’étape 8/

10/ Sauvegarder l’image au format désiré
Plusieurs options sont possibles en fonction du type de données que vous souhaitez sauvegarder :
10.1/ Enregistrer uniquement l’image sans les autres paramètres (orientation, échelle) :
Dans la fenêtre de l’image :
> File > Save image/slice as JPEG (ou tout autre format)

10.2/ Enregistrer l’image avec l’orientation et l’échelle :
> File > Save image display as JPEG (ou tout autre format) 



*/ Annexes
1/ Annexe 1     : espace mémoire 

De  manière  générale,  le  traitement  de  données  astrophysiques  consomme  beaucoup  de  mémoire
informatique. Une nuit d’observation correspond à plusieurs Go. Un fichier .fits pour une acquisition de 60
secondes pèse 16 Mo.
De plus, lors du traitement, de nombreux fichiers vont être créés.
> Il faut donc réserver la place nécessaire sur l’ordinateur.

Par ailleurs, il faut indiquer à AIJ la mémoire de travail qui lui est dédié (il travaille par défaut avec 512 Mo
de mémoire).
> Pour augmenter la mémoire de travail dédiée à AIJ: > Edit > Options > Memory & Threads (pas
plus de 75 % de la RAM de votre ordinateur).

2/ Annexe 2     : suppression d’images indésirables dans un jeu de données

Lors d’un traitement de données, vous pouvez parfois souhaiter supprimer une ou plusieurs images d’un jeu
de données car elles sont jugées indésirables (erreur de pointage, mauvaise orientation, saturation, etc).

> Visualiser la séquence d’images à traiter et repérer la ou les images à supprimer
→ Par exemple dans le cas ci-dessous, une image (à droite) possède une orientation non conforme (cadre
rouge) à l’ensemble du reste des données (à gauche)
> Pour la supprimer de la séquence affichée, cliquer sur l’icône en haut à droite (flèche bleue).
→ Cette opération ne supprime pas l’image de votre dossier mais uniquement de la séquence affichée.



3/ Annexe 3     : Quelques conseils pour obtenir une «     belle     » image couleur.

Attention : il  ne s’agit  ici  que de quelques pistes et ces quelques conseils ne vous donneront  pas une
solution systématique pour imager les objets célestes …
Il faut tester par soi-même même ce qui fonctionne le mieux selon ses propres objectifs.

> Ne pas multiplier les cibles : Mieux vaut acquérir plusieurs images sur un même objet qu’une seule
image pour plusieurs objets.

> Multiplier les poses sur le même objet :Une « image » astro peut être l’addition de plusieurs dizaines
d’images qui accumulent plusieurs heures de pose.

> Prendre garde à ne pas saturer le capteur CCD : Selon la magnitude de l’objet, poser de 15 s à 120 s
de manière à ne pas saturer le capteur CCD : lorsqu’il y a saturation, les informations sont perdues … et ne
peuvent plus être exploitées !

> Limiter le temps de pose pour augmenter le rapport signal/bruit : Mieux vaut 10 poses de 2 minutes
empilées sur un objet faible qu’une seule et unique pose de 20 minutes.

Une image peut également être la combinaison (calques) de zones obtenues avec des temps de pose
différents pour faire ressortir les différentes zones.

> Adapter les filtres à l’objet observé :



Les processus physiques se déroulant au sein des objets astrophysiques différent selon la nature de ces
derniers.  Chaque type d’objet possède donc des caractéristiques spectrales qui lui  sont propres et par
conséquent, certains filtres seront plus adaptés pour l’observation de tel ou tel objet. 
Sans rentrer dans le détail de ces processus, voici quelques conseils d’utilisation de filtres en fonction du
type d’objet observé : 

> Amas ouvert d’étoiles  et amas globulaires : Il peut être intéressant de travailler avec les filtres SDSS
u, g, r et i qui ont des bandes passantes larges et qui couvrent la quasi-totalité du spectre de la lumière
visible.

>Galaxies : Filtres SDSS g,r et Halpha. Cet ensemble doit permettre de bien imager l’ensemble des étoiles
de la galaxie avec les filtres à bandes larges  (g,  r)  et  le filtre  Halpha pour  faire ressortir  les nuages
d’hydrogène présents dans la galaxie.

>Nébuleuses : Filtres SDSSg, OIII et Halpha. Le filtre OIII atténue fortement les étoiles mais permet de
faire ressortir les nébulosités.


